Back to overview
Resolved

Degraded Performance — High Latency in Voice Agent Calls

May 26, 2026 at 9:46am UTC
Affected services
Debales AI Platform (debales.ai)

Resolved
May 28, 2026 at 4:54pm UTC

Resolved – The performance degradation affecting our Voice Agents has been resolved. Call latency has returned to normal levels, and all systems are fully operational.

Updated
May 27, 2026 at 3:44pm UTC

The root cause has been fixed internally. We are currently observing the system to ensure stability.

Created
May 26, 2026 at 9:46am UTC

We are currently experiencing degraded performance on our Voice Agents, resulting in higher-than-usual latency during calls. Our engineering team is actively working on a fix.
Calls are still connecting, but users may notice delays in agent responses until the issue is fully resolved.
We will share the next update shortly. Thank you for your patience.